Previous Article Next Article yum安裝套件出現相容性問題
Posted in Linux

yum安裝套件出現相容性問題

yum安裝套件出現相容性問題 Posted on 2012 年 10 月 01 日Leave a comment

我已安裝了 httpd ,但之後我想再裝上 httpd-devel 就一直出現底下訊息以致無法成功

–> Finished Dependency Resolution
httpd-devel-2.2.3-65.el5.centos.x86_64 from updates has depsolving problems
–> Missing Dependency: httpd = 2.2.3-65.el5.centos is needed by package httpd-devel-2.2.3-65.el5.centos.x86_64 (updates)
httpd-devel-2.2.3-65.el5.centos.i386 from updates has depsolving problems
–> Missing Dependency: httpd = 2.2.3-65.el5.centos is needed by package httpd-devel-2.2.3-65.el5.centos.i386 (updates)
Error: Missing Dependency: httpd = 2.2.3-65.el5.centos is needed by package httpd-devel-2.2.3-65.el5.centos.x86_64 (updates)
Error: Missing Dependency: httpd = 2.2.3-65.el5.centos is needed by package httpd-devel-2.2.3-65.el5.centos.i386 (updates)
You could try using –skip-broken to work around the problem
You could try running: package-cleanup –problems
package-cleanup –dupes
rpm -Va –nofiles –nodigest

試了它所提示的解法,但~~都無效

最後絕招就是 yum remove httpd ,再 yum install httpd httpd-devel ,及其它相關套件再把它安裝回來就好了,

唉,搞半天

 

發表迴響

你的電子郵件位址並不會被公開。 必要欄位標記為 *